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Customer Support

Contact: Click Here

Web site: http://thepluginsite.com

User Forum: http://www.graphicsgalaxy.com/forums/thepluginsite/viewforum.php?f=26

If You have some suggestions for improving ContrastMaster, please contact us.
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Compatibility

ContrastMaster works under Windows 95, 98, NT, ME, 2000, XP, Vista as well as MacOS X. It supports the 8−bit RGB
and 16−bit RGB color modes.

You need one of the following applications to use the MacOS X versions:

Adobe Photoshop (Version 7 and higher)• 
Adobe ImageReady (Version 7 and higher)• 
Adobe Photoshop Elements (Version 2 and higher)• 
Adobe Illustrator (Version 10 and higher)• 
ACDSystems Canvas (Version X and higher)• 
CiEBV Photoline 32 (Version 11.52 and higher)• 
Corel Painter (Version 9 and higher)• 
LemkeSoft GraphicConverter (Version 5.7 and higher)• 
Macromedia Fireworks (Version 7 (MX 2004) and higher)

... and it probably works in several graphics applications that support Photoshop plugins.

• 

You need one of the following applications to use the Windows versions:

Adobe Photoshop (Version 3 and higher)• 
Adobe Photoshop Elements• 
Adobe PhotoDeluxe• 
Adobe After Effects (Version 4.1, 5.0 and 5.5, but not animatable)• 
Adobe Illustrator (Version 7 and higher)• 
Adobe ImageReady (Version 2 and higher)• 
ACD Photo Canvas (Version 2 and higher) (Delivered with some editions of ACDSee)• 
ACD Photo Editor (Version 3 and higher) (Delivered with some editions of ACDSee)• 
ACD Canvas X• 
Aurora Borealis Mandala Painter (Version 3 and higher)• 
CADlink SignLab (Version 5 and higher)• 
CDH Image Explorer Pro (Version 4 and higher)• 
CiEBV Photoline 32 (Version 5 and higher)• 
Corel Draw (Version 6 and higher)• 
Corel Paint Shop Pro (Version 10 and higher)• 
Corel PhotoPaint (Version 9 and higher)• 
Corel Bryce (Version 4 and higher)• 
Corel/Metacreations Painter (Version 6 and higher)• 
Deneba Canvas (Version 6 and higher)• 
Discreet Combustion (Version 2 and higher, but not animatable and preview is blueish)• 
Equilibrium DeBabelizer Pro (Version 5 and higher)• 
GIMP (Version 1.2.4 and higher with the PSPI plugin) (Preview doesn't work correctly and may crash if you scroll
it too often)

• 

Image Analyzer (with the 8bf Interface plugin) (F reeware from http://meesoft.logicnet.dk/)• 
imageN (Freeware from www.pixoid.com)• 
IrfanView (Version 3.85 and higher, Freeware from www.irfanview.com)• 
Jasc Paint Shop Pro (Version 4.12 and higher)• 
KnowledgeAdventure HyperStudio (Version 4.2 and higher)• 
Macromedia Freehand (Version 7 and higher)• 
Macromedia Fireworks (Version 2 and higher, but transparency isn't correctly displayed in the preview)• 
Magix Xtreme Photo Designer (Version 6 and higher, but applying the plugin to a selection or object causes
problems and sometimes random crashes occur, Freeware from
http://www.magix.com/us/free−downloads/free−software/xtreme−photo−designer/)

• 

Mediachance PhotoBrush• 
Megalux Ultimate Paint (Version 2 and higher)• 
Megalux Ultimate FX (Freeware that is not developed anymore)• 
Microfrontier Digital Darkroom (Version 1.2 and higher)• 
Micrografx Picture Publisher (Version 8 and higher, but the preview zoom won't work)• 
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Microsoft Image Composer (Version 1.5 and higher, but dragging the preview isn't possible)• 
Microsoft PhotoDraw 2000• 
Microsoft Picture It! Digital Image Pro (Version 7 and higher, but a 100% zoom may not work correctly and
Cancel sometimes produces a crash)

• 

Newave Chaos Fx: Twilight'76 (Version 1.2 and higher)• 
New World Focus PhotoEditor (Version 4 and higher)• 
Picmaster (Version 1.25 and higher)• 
Plugin Commander Pro (Version 1.5 and higher)• 
PluginMaster• 
PhotoFiltre Studio (Version 7 and higher)• 
QFX / QFX LE (Version 7 and higher)• 
Right Hemisphere Deep Paint• 
Satori PhotoXL (Version 2.29 and higher)• 
Serif PhotoPlus (Version 6 and higher) (Version 6 is freeware from www.freeserifsoftware.com)• 
SigmaPi Pixopedia 24 (Version 1.0.5 and higher)• 
SigmaPi NiGulp (Version 1.5 and higher) (Freeware from http://www.sigmapi−design.com/freeware.htm)• 
Stoik ImageMan Pro (Version 5 and higher)• 
ThinkTank Ameri−Imager (Version 2 and higher)• 
Ulead Gif Animator (Version 4 and higher)• 
Ulead PhotoImpact (Version 4 and higher)• 
VCW Vicman's Photo Editor (Version 6.9 and higher, but preview dragging causes crash) (Freeware from
www.photo−editor.net)

• 

WebSuperGoo Achroma• 
Xara X• 
XnView (Version 1.70 and higher) (Freeware from www.xnview.com)

It hasn't been tested, but should work with:

Ability PhotoPaint Studio♦ 
Adobe PageMaker (Version 6 and higher)♦ 
Adobe LiveMotion♦ 
BananaSoft TwistedPixel♦ 
CADlink SignLab (Version 5 and higher)♦ 
Corel/MetaCreations Painter 5.5♦ 
Corel/MetaCreations Art Dabbler♦ 
Corel Photo House (Version 2 and higher)♦ 
Corel Xara 2♦ 
DigisoftDirect ImagePro 2K1♦ 
Equilibrium DeBabelizer Pro (Version 4.5)♦ 
Fractal Design Detailer♦ 
Macromedia Director (Version 6 and higher)♦ 
MGI PhotoSuite (Version 4 or higher)♦ 
Newtek Lightwave (Version 5.6 or higher)♦ 
Newtek Inspire 3D♦ 
Newtek Aura (Version 2 and higher, but probably not animatable)♦ 
PM Imagic♦ 
Ulead PhotoExpress (Version 2 and higher)♦ 

It does not work with:

Adobe ImageStyler (Doesn't support filter plugins)♦ 
Adobe Premiere (Up to Version 5.1: Renders only black to image)♦ 
ArcSoft PhotoStudio 2000 (Up to Version 4.1: Does not support PhotoShop plugins)♦ 
Datatech ImageMan (crashes when dragging preview and crashes when applying effect)♦ 
FixFoto (Up to Version 2.74: Preview is segmented and final result contains an overlayed thumbnail)♦ 
discreet 3D Studio MAX (Up to Version 4.2: Background image isn't displayed; Color selection dialog
doesn't work; Renders a distorted red/green pattern)

♦ 

Macromedia xRes (Crashes on loading plugin)♦ 
Metacreations Painter 5 (Everything works except final rendering)♦ 
Microsoft Image Composer 1.0 (Does not recognize the plugin)♦ 
SPG ColorWorks: Web (Up to Version 4: Everything works except final rendering)♦ 

• 

ContrastMaster Manual 5

http://www.freeserifsoftware.com
http://www.sigmapi-design.com/freeware.htm
http://www.photo-editor.net/
http://www.xnview.com/


Installation

Under Windows

Method 1: Using Plugin Installer

After double clicking the downloaded file, the installation will be started. On the "Select Destination Location" dialog you
can enter the location where the ContrastMaster files will be installed. If you want to use the Plugin Installer tool later, you
can keep the installation path that is suggested by the installer.

At the end of the installation the Plugin Installer window will appear and display a list of compatible applications that are
installed on your computer. The list may not be as long as the one in the screen shot below, but there should be at least
one application mentioned. The application at the top of the list is always activated. If you want to install ContrastMaster
into other applications, you should activate them, too. Then please press the Install button to copy the ContrastMaster
plugin into the plugin folder of the selected application(s). Finally leave Plugin Installer with the Exit button.
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If your application should not be listed in Plugin Installer, you can manually add the plugin folder of your application with
the Add Folder button in Plugin Installer. If Plugin Installer terminates telling you that it didn't manage to find an
application, you can try Method 2 below.

If you install a new application and want to use ContrastMaster with it, please run Plugin Installer again from the Start >
Program > BW Styler menu and repeat the steps mentioned above.

Method 2: Without Plugin Installer

Method 1 is usually the most convenient way of installing ContrastMaster. But some people keep their plugins in folders
outside an application's plugin folder or some people use an application that is not recognized by the Plugin Installer tool.
In this case you can choose another folder in the "Select Destination Location" dialog during installation and ignore the
Plugin Installer by closing it with the Exit button.

If you are unsure which folder to choose in the "Select Destination Location" dialog please see the general installation
instructions below.

Under MacOS X

When installing ContrastMaster for MacOS X you need to choose the plugins folder of your graphics application. For
Photoshop that would be the Plug−Ins sub folder inside the Photoshop folder. If you are unsure which folder to choose
during installation, please see the general installation instructions below.

General Installation Instructions

The following instructions can be used if there were problems during the ContrastMaster installation.

Adobe Photoshop / Photoshop Elements / Illustrator / ImageReady

Make sure you install the plugin into the "Plugins" or "Plug−ins" sub folder inside the Photoshop, Illustrator or ImageReady
folder. We recommend that you create a sub folder called ContrastMaster in that folder and install it there. After restarting
the application, you will find it in the Filter menu.

Adobe PhotoDeluxe

Make sure you install the plugin into the "Plugins" or "Plug−ins" sub folder inside the PhotoDeluxe folder. We recommend
that you create a sub folder called ContrastMaster in that folder and install it there. After restarting the application, you
need to make PhotoDeluxe display all menu items if you haven't already done that. To display all menu items go to the
Preferences sub menu of the File menu and choose the last item ("Extend Menu" or something similar) on the sub menu
You will find the plugin in the Effects menu.

Adobe PageMaker

Make sure you installed the plugin into Rsrc/.../Plugins/Effects folder inside the PageMaker folder. We recommend that
you create a sub folder called ContrastMaster in that folder and install it there. After restarting PageMaker, you will find the
plugin in the Element> Image> Photoshop Effects menu.

CiEBV Photoline 32

Choose 'File options' or 'Extended' from the Options menu, click on the 'Plug In Path' tab and select the folder where the
plugin is to be located. After pressing OK, the plugin will appear at the bottom of the Filter menu.

Corel Photo−Paint

Press <Ctl + J> to display the Options dialog, select Plugins from the list box on the left, press the Add button and choose
the location of the plugin. The plugin will appear in the Effects menu right after the Options dialog disappeared.
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Corel Photo House

Select Effects > Plug−in Effects > Add/Remove Plugin Effects. Press the Add button and select the folder where the
plugin is located. After pressing OK, the plugin will appear on the Effects > Plugin Effects menu.

Deneba Canvas

Select "Preferences" from the File menu. In the Preferences dialog select the Paint tab. Press the Plug−ins button and
select the folder where the plugin is located. After restarting Canvas, the plugin will appear on the Image > Filter sub
menu

imageN

Select "Plug−ins" from the Configure menu. When the Plugins dialog appears press the Search button. After imageN has
searched all your drives for plugins (which can take some time), the plugin will appear on the plugin list, too. To apply a
plugin, select it from the list and press the Test button.

IrfanView (Version 3.85 and higher)

Make sure that an image is displayed in IrfanView, then select Image > Effects > Adobe 8BF filters. In the appearing
dialog press the "Add 8BF filters" button and choose the folder where you installed the plugin.  It will now appear in the list
on the left. To run the plugin double click on the appropriate item or select it and press the "Start selected filter" button.

Jasc Paintshop Pro 4 − 6

Choose "Preferences" from the File menu, press the Plugin Filters tab and select the folder, where you installed the plugin
from the Plugin Filters tab of the Preferences dialog. After pressing OK, the plugins will appear on the Plugin Filters sub
menu of the Image menu.

Jasc Paint Shop Pro 7

Choose Preferences > File Locations from the File menu, press the Plugin Filters tab and select the folder where you
installed the plugin. After pressing OK, the plugin will appear in the Plugin Filters sub menu of the Effects menu.

Jasc Paint Shop Pro 8 & 9

Choose Preferences > File Locations from the File menu, select Plug−ins from the list box, press the Add button, press
the Browse button and select the folder where you installed the plugin. After pressing OK twice, the plugin will appear in
the Plugin Filters sub menu of the Effects menu.

Macromedia Freehand

Make sure you install the plugin into the English/Xtras sub folder inside the Freehand folder. We recommend that you
create a sub folder called ContrastMaster in that folder and install it there. After restarting Freehand, you will find the
plugin in the Xtras menu.

Macromedia Fireworks

Choose "Preferences" from the File menu and activate the Photoshop Plug−ins check box in the Folders section of the
Preferences dialog. Then select the folder, where you installed the plugin by pressing the "..." or Browse button. After
restarting Fireworks the plugins will be displayed at the bottom of the Xtras menu.

Megalux Ultimate Paint

Choose "Preferences" from the Options menu, click on the Plugins tab and select the folder where the plugin is located.
After pressing OK, the plugin will appear in the Adobe sub menu of the Image menu.

Metacreations Painter / Fractal Design Detailer

Choose Preferences > Plugins... from the Edit menu and select the folder where the plugin is located. After restarting
Painter/Detailer, the plugin will appear on the Effects menu.

Microfrontier Color It!

Make sure you install the plugin into the "Plug−ins" sub folder inside the Color It! folder. We recommend that you create a
sub folder called ContrastMaster in that folder and install it there. After restarting the application, you will find them in the
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Filter menu.

Microsoft Photodraw 2000

Select Tools > Options and press the Plugin tab. Press the Browse button and select the folder where the plugin is
located. Finally press OK on the Options dialog. Choose Format > Effects > Plug−ins and select the plugin in the combo
box at the top of the Plug−ins dialog.

Micrografx Picture Publisher

Make sure you install the plugin into the "Plugins" sub folder inside the Picture Publisher folder. We recommend that you
create a sub folder called ContrastMaster in that folder and install it there. After restarting Picture Publisher you will find
the plugin in the Effects menu.

Right Hemisphere Deep Paint

Select File > Preferences > Directories and press the Browse button next to the Photoshop Plugins text box. In the file
dialog, select the folder where the plugin is located and press OK. Then press OK on the Directories dialog. After
restarting Deep Paint, you will find the plugin in the Filters menu.

SPG Colorworks: WEB

Choose "Preferences" from the File menu and select the folder where you installed the plugin, at the bottom of the
Preferences dialog. After pressing OK the plugin will be accessible from the Plugin Filter Selector dialog which is available
from the Effects menu.

Ulead Photo Impact

Choose "Preferences" from the File menu and select the folder where you installed the plugin, in the Plugins tab of the
Preferences dialog. After restarting Photo Impact the plugin will be displayed in the Photo Wiz category on the Effect
menu.

Ulead Gif Animator

Choose "Preferences" from the File menu, click on the Plugin Filters tab and select the folder where the plugin is located.
After restarting Gif Animator the plugin will appear in the Filters menu.

Ulead PhotoExpress

Choose "Preferences" from the File menu and select the folder, where you installed the plugin, in the Plug−Ins tab of the
Preferences dialog. After restarting PhotoExpress the plugin will be displayed in the Photo menu.
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Plugin Workflow

When correcting photos it is often important in which order you perform certain correction steps. Applying the same
correction steps in a different order may produce a less good result.

Using ContrastMaster with other PhotoWiz Plugins

It is best to apply ContrastMaster after ColorWasher, because ContrastMaster may amplify color casts. However, if you
adjust the contrast in ColorWasher, ContrastMaster may not be able to work 100% effective. So in ColorWasher better set
the Contrast, Shadows and Highlights sliders to zero. If it is necessary to perform any contrast adjustments in
ColorWasher, please only reduce the contrast but do not increase it.

Although ContrastMaster also brightens up shadows, it works better on brighter images. ContrastMaster does not brighen
deep shadows as effectively as LightMachine. So if an image is quite dark or bright and needs strong brightness and
shadow/highlight corrections, it is better to apply LightMachine before ContrastMaster. Better set the the Contrast, Amplify
and Local Contrast sliders in LightMachine to zero, otherwise ContrastMaster may not be able to work as effectively.
However, if a contrast adjutsment is necessary in LightMachine to make the shadow/highlight correction look better, do
not hesitate to apply it.

If the image is not too dark or bright, you can also use LightMachine after ContrastMaster, which is probably more
convenient. Another possibility would be to apply a shadow/highlight correction with LightMachine, then run
ContrastMaster and finally use LightMachine's Virtual Studio mode for some selective effects.

It is better to apply B/W Styler after ContrastMaster, otherwise you will have to make sure that some contrast features in
B/W Styler are deactivated, which is less convenient. If you nevertheless want to apply B/W Styler before ContrastMaster,
please do not use the controls on the General tab sheet in Expert Mode (except the Brighten slider), the Paper Grade
feature and only the first two sliders in Development mode in B/W Styler. With "do not use" I mean that you should keep
them at their default setting or zero.

Using ContrastMaster before FocalBlade is recommended. If you only apply light sharpening with FocalBlade before using
ContrastMaster, there should not be any problem.

ContrastMaster and Other Tools

It is wise to apply ContrastMaster at a certain step, because it will allow you to avoid some problems and better adjust the
ContrastMaster effect. ContrastMaster can amplify color casts and its effect can be better judged on brighter images.

So it is best to apply ContrastMaster to an image that was color corrected and was brightness and shadow/highlight
adjusted. It is also good to correct lens vignetting in a photo before using ContrastMaster, because a strong
ContrastMaster effect will amplify it. You will get a smoother effect if you apply ContrastMaster before an image was sized
down, but the rendering will also take longer.

Please do not adjust the contrast of an image in a strong manner before running ContrastMaster, otherwise
ContrastMaster may not work 100% effective. In Photoshop do not use the white and black slider thumbs of the Levels
tool, do not create a S−shaped curve in the Curve tool or use the Contrast slider of the Brightness/Contrast tool before
running ContrastMaster. In Camera RAW keep the Contrast and Clarity sliders set to zero and do not use the Tone Curve
tool.

It is always good to run a noise reduction tool on a bad quality image before or after applying ContrastMaster. This will
keep ContrastMaster from making noise even more visible or reduce the noise that was made visible by ContrastMaster.

Better apply stronger sharpening after running ContrastMaster. But doing some light sharpening before applying
ContrastMaster should cause no big problems.
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General Usage

Before using ContrastMaster you have to start your preferred image editing application and open an image or photo.
Please note that ContrastMaster only works on images in 8bit or 16bit RGB mode. If your image is grayscaled, has only
256 colors or is a CMYK image, you have to convert it in your image application to RGB before you can start working on it
with ContrastMaster. If the opened image is not RGB, ContrastMaster will appear grayed out on the menu.

To run ContrastMaster please open the menu that leads to the plugin filters (usually the "Filter", "Effects" or "Image −>
Plug−ins" menu) and choose "ContrastMaster" from the "PhotoWiz" sub menu.

Basic Design

ContrastMaster features 6 different modes which can be selected from the Mode combo box at the top. When you run
ContrastMaster for the first time you should explore Novice mode first. For more information on the various modes, please
read the Modes page.

The Preview

On the left−hand side of the dialog box is the preview box that shows the effect. When executing ContrastMaster it will fit
the full image in the preview. This is also the recommended way to work on an image. If you zoom into the image, only a
part of the image is displayed in the preview. The image can then be moved by holding down the right mouse button (or
the left mouse button in case the hand tool at the top is activated) and moving the mouse. While it is moved, the original
image is shown, and after you release the left mouse button the preview is recalculated.
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The Preview Tab Buttons

Above the preview you can see three tab buttons called Preview 1, Preview 2 and Preview 3. With their help you can
quickly switch between three different filter settings and compare them. Only the effect of the selected Preview tab button
will be rendered when you press OK. Right clicking on the tab buttons displays a context menu for copying the settings of
the currently selected tab to one of the other tabs.

The Tool Icons

The hand icon is activated by default. The hand tool lets you scroll the preview by dragging with the pressed down left
mouse button. Even if the hand tool is not activated, you can always scroll the preview with the help of the right mouse
button. If you activate the color picker icon, you can click somewhere on the preview to select a certain color for one of the
two color boxes on the Mask tab sheet. The color picker tool is not available in Novice mode. The split view tool lets you
drag the separation line between the split views or set a focus point if the Multiple check box is active. It automatically
activates split view if you click on it.

Changing the Window Size

You can enlarge the ContrastMaster preview window to also make the preview larger. However, doing that will also
increase the time that ContrastMaster needs to update the preview. If you use an old and slow computer, it isn't
recommended to enlarge the ContrastMaster dialog. On the contrary you can also make it smaller to make
ContrastMaster render the preview faster.

To resize the ContrastMaster window and make the preview larger under Windows you have to move your cursor to the
border of the ContrastMaster dialog. The cursor will then turn into a double arrow. Holding down the left mouse button and
dragging the mouse changes the size of the window. Double clicking the ContrastMaster title at the top left corner will
maximize the window, double clicking it again will restore the old window size. Under MacOS X you need to drag the
handle at the bottom right of the ContrastMaster dialog to make the dialog larger.

The Help Text Box

The Help feature makes it easier for new users to get started and makes it possible to use ContrastMaster without a
glance at the manual. If you move the mouse over a certain control, the text box will display an explanation about the
control. After you have made yourself familiar with ContrastMaster, you may deactivate these explanations by deactivating
the check box in the bottom right corner of the Help box. We recommend that you keep it nevertheless activated.

The Zoom Buttons and Zoom Check Box

At the right bottom of the preview box you can see a '+' and '−' button with a percentage number in between. These zoom
buttons let you adjust the size of the image in the preview box. "100%" means that the original size of the image is
displayed. "Fit" means that the whole image is always displayed in the preview.

By default when starting ContrastMaster the zoom rate will be automatically set to make the image fit into the preview. If
you hold the Shift key when pressing one of the zoom buttons, the zoom factor will be set to the highest (100%) or lowest
acceptable value (fitted zoom). If you hold the CTRL key when pressing one of the zoom buttons, the zoom factor will be
set to the highest (100%) or lowest possible value (6%). Some very old applications (e.g. Corel Photopaint 7 or Corel Xara
2) don't support preview zooming. In this case the zoom buttons won't work.

To jump from one preview zoom rate to another you can use the zoom combo box which is located between the two
zoom buttons.
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Auto Preview

If the Auto Preview check box is deactivated, the effect will not be rendered in the preview. Instead you will see the
original image. You can also see the original image by right clicking on the preview. A deactivated Auto Preview can also
be used quickly change slider values without having the preview updated after each change.

Split View & Multiple

ContrastMaster offers various split views for comparing the original with the processed image. To move the separation
lines or set a focus point you need to activate the split view tool at the top right corner of the preview. For more
information, please read the Split View page.

Sliders

Sliders can be used to select a certain value within a specific value range. To do that you can drag the slider thumb with
the mouse (or keyboard), click somewhere on the slider bar for large value steps or use the two arrow buttons for small
value steps. Alternatively you can also enter a numerical value in the text box at the right of the slider bar.

You can also use the mouse wheel to change the slider values. You need to give the slider the focus by clicking on it or
using the tab key. Then you can scroll the mouse wheel to move the slider thumb. After you stop moving the wheel the
preview will automatically update.

You can hold down the Shift key while dragging the slider thumb to make the preview update with every movement of the
thumb.

OK, Cancel and ?

Clicking on the OK button exits ContrastMaster and applies the effect to the image. The current settings are saved and
restored when you use ContrastMaster again (bur only if you keep the Previous Settings item activated in the On Start Up
combo box in Preferences).

The Cancel button simply exits ContrastMaster without changing the image. The current settings will be lost immediately.
If you hold down the CTRL key while clicking on Cancel, you will be prompted for Cloak Mode. In Cloak Mode the current
settings will be applied to the image without displaying the ContrastMaster dialog. For more information, please read the
Cloak Mode page.
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Step By Step Guide

Sample Workflow 1 (Novice)

1. Run ContrastMaster and switch to Novice Mode.

2. Click on the Reset button.

3. Try the options of the arrow−down button menu on the Mix tab sheet and keep the one you like best.

4. Use the three sliders on the Mix tab sheet to improve the effect.

5. Try the sliders on the Global tab sheet to improve the effect. Be careful to not use too extreme values.

6. Press OK when you are satisfied.

Sample Workflow 2 (Intermediate)

1. Run ContrastMaster and switch to Novice Mode.

2. Click on the Reset button.

3. Switch to Dynamic Contrast Mode and adjust the effect until you are satisfied.

4. Switch to Adaptive Contrast Mode and adjust the effect until you are satisfied.

5. Switch to Local Contrast Mode and adjust the effect until you are satisfied.

6. Switch to Novice Mode and compare its combined effect with the effects of the three previous modes.
You can do that by switching back and forth between the modes (e.g. by using the cursor keys with the
activated Mode combo box).

7. If you like the effect in one of the Contrast modes best, switch back to that mode. But if you like the
effect in Novice Mode, play a bit with the three sliders on the Mix tab to improve the effect.

8. Use the sliders on the Global tab sheet to improve the effect. Be careful to not use too extreme
values.

9. Press OK when you are satisfied.

Sample Workflow 3 (Advanced)

1. Run ContrastMaster and switch to Expert Mode.

2. Click on the Reset button.

3. Switch to Dynamic Contrast Mode and adjust the effect until you are satisfied.

4. Switch to Adaptive Contrast Mode and adjust the effect until you are satisfied.

5. Switch to Local Contrast Mode and adjust the effect until you are satisfied.

6. Now compare the effect of these three modes with the combined effect of Expert Mode by switching
back and forth between the modes (e.g. by using the cursor keys with the activated Mode combo box).
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7. If you like the effect in one of the Contrast modes better, choose it in the arrow−down button menu of
the Mix tab in Expert Mode. For example, if you like the Dynamic effect best, you can select "Dynamic
Contrast" from the arrow−down button menu to use it in Expert Mode.

8. Play a bit with the three sliders and the three Mix combo boxes on the Mix tab to improve the effect.
The higher the value of one of the three slider, the more of the appropriate effect will be mixed into the
combined effect.

9. Try the sliders on the Global tab sheet to improve the effect. Be careful to not use too extreme values.

10. Adjust the saturation on the Saturation tab sheet.

11. You can weaken the overall effect with Fade slider on the Mask tab sheet and the remove the effect
from certain areas of the image with the other options on the same tab sheet.

12. Press OK when you are satisfied.

Sample Workflow 4 (Expert)

1. Run ContrastMaster and switch to Expert Mode.

2. Click on the Reset button.

3. To display only the dynamic contrast effect choose "Dynamic Contrast" on the arrow−down button
menu of the Mix tab sheet. Alternatively you can also set the Adaptive and Local sliders on the Mix tab
sheet to zero. Switch to the Dynamic tab sheet and adjust the effect until you like it.

4. To display only the only show the adaptive contrast effect by choose "Adaptive Contrast" on the
arrow−down button menu of the Mix tab sheet. Alternatively you can also set the Dynamic and Local
sliders on the Mix tab sheet to zero. Switch to the Adaptive tab sheet and adjust the effect until you like
it.

5. To display only the only show the Local contrast effect by choose "Local Contrast" on the
arrow−down button menu of the Mix tab sheet. Alternatively you can also set the Dynamicand Adaptive
sliders on the Mix tab sheet to zero. Switch to the Local tab sheet and adjust the effect until you like it.

6. To see the combined effect please choose "Reset" from the arrow−down button menu of the Mix tab
sheet.

8. Play a bit with the three sliders and the three Mix combo boxes on the Mix tab to get the best mixture
of all three effects. The higher the value of one of the three slider, the more of the appropriate effect will
be mixed into the combined effect. Also use the Mix combo boxes if necessary.

9. Try the sliders on the Global tab sheet to improve the effect. Be careful to not use too extreme values.

10. Adjust the saturation on the Saturation tab sheet.

11. You can weaken the overall effect with Fade slider on the Mask tab sheet and the remove the effect
from certain areas of the image with the other options on the same tab sheet.

12. Press OK when you are satisfied.

Portrait Workflow

1. Run ContrastMaster and follow one of the above sample workflows to adjust the effect.

2. If you are in Novice Mode, please switch to Expert Mode. Otherwise stay in your current mode.

3. To remove the contrast effect from the skin of the person in the portrait, click the color picker tool at
the top right corner of the preview.
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4. Click somewhere on the preview to pick the skin color.

5. You will notice that the Mask tab sheet was automatically displayed. You will see two color boxes on
it. One of it is selected. Now use the slider at the right of the selected color box and gradually increase
its value. The preview will bow remove from all image areas that have the picked color.

6. Press OK when you are satisfied.

ContrastMaster Manual 16



Batch Processing

Scripting Or Cloak Mode?

ContrastMaster 1.02 for Windows now offers scripting support in Photoshop, Paint Shop Pro and Debabelizer. This
means that you can record the effect settings in actions/scripts in these applications. The recorded action or script can
then be used for batch processing. ContrastMaster will automatically suppress the dialog and immediately render the
effect to the image. You need to record a new action or script for every ContrastMaster effect that you want to apply
during batch processing.

If you are using the  Mac version, a previous Windows version or any other application under Windows (e.g.
Fireworks), the ContrastMaster dialog is not automatically suppressed during batch processing. So you need to use Cloak
Mode, which suppresses the dialog when activated. You only need to record a single action or script with ContrastMaster
and can always use it during batch processing, because there are no effect settings recorded in the action or script.

Even if you are using ContrastMaster 1.02 for Windows in Photoshop, Paint Shop Pro and Debabelizer, you can still
decide to use Cloak Mode. If Cloak Mode is activated, ContrastMaster will ignore the scripting values and apply the last
used setting. Using Cloak Mode has the advantage that you do not need to record a new action or script for every new
ContrastMaster effect that you want to apply, but you also always need to set a new effect in ContrastMaster before you
can start with batch processing. On the other hand if you want to use ContraMaster as a smart filter in Photoshop CS3
and CS4, please deactivate Cloak Mode after batch processing, otherwise ContrasMaster will not work properly as a
smart filter.

Cloak Mode

If you decided to use Cloak Mode, you can activate it by holding down the CTRL key when clicking on the Cancel button.
The message box above will appear then. After pressing YES, the current settings will be saved and ContrastMaster will
be exited without rendering any effects to the image. Alternatively you can also hold down the CTRL key and press the
OK button, but then the effect will be additionally applied to the image.

When you run ContrastMaster again by choosing it from the Filter menu of your image application, the dialog of
ContrastMaster won't show up and the previous settings will be rendered immediately to the image. So if you have the On
Start Up combo box on the Prefs tab sheet set to "Default Settings", this setting is ignored in Cloak Mode and the previous
settings are applied. However, if you have On Start Up set to "Logged Settings", ContrastMaster will search for
automatically logged settings for each image and apply them if they are available.

After you have processed your series of photos in Cloak Mode you can uncloak ContrastMaster again. To do that, keep
the the Shift key pressed down when selecting ContrastMaster from the filter menu in your image application. This will
display the ContrastMaster dialog again and exit Cloak Mode.

Alternatively you can also delete the file CMCloak.ini in the ContrastMaster folder. But this is just an emergency strategy.
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Batch Processing in Photoshop

Photoshop offers a Batch feature on its File > Automate menu. This feature lets you batch process a series of images with
the help of a Photoshop action. So if you want to batch process images in Photoshop you only need to record an action
that contains ContrastMaster.

Recording an action with ContrastMaster:

1. Open an image in Photoshop.

2. Switch to the Actions palette on the right and create a new action by using the New Action button or the pop−up palette
menu.

3. Choose ContrastMaster from the Filter menu.

4. If you want to use Cloak Mode, continue with step 5, because you can adjust the effects settings later. If you do not
want to use Cloak Mode, you now need to adjust the effect settings in ContrastMaster, so that they are recorded in the
action.

5. Press OK on the ContrastMaster dialog.

6. Press the Stop button on the Action palette. Now you have your ContrastMaster action that you can use with File >
Automate > Batch.

Batch processing a series of images with ContrastMaster:

1. Open one of the images from the image series.

2. If you want to use Cloak Mode, run ContrastMaster, adjust its settings and enter Cloak Mode by holding the CTRL
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key and clicking on the Cancel button. If you do not want to use Cloak Mode, continue with step 3, because you do not
need to run ContrastMaster.

3. Select File > Automate > Batch.

4. In the Batch dialog make sure that your ContrastMaster action is selected.

5. Set the other batch options and click on OK to run it.

If you are using Cloak Mode, please read here: If you want to batch process another series of images with other
ContrastMaster settings, please uncloak ContrastMaster as mentioned above, adjust the settings and return to Cloak
Mode again. You don't need to create another action for that purpose as you would need to do for other plugins. If you
want to apply individual ContrastMaster settings to each image during batch processing, run the action without activating
Cloak mode. In this case the ContrastMaster dialog will pop up for each image.

If you do not use Cloak Mode, read here: You need to record a new action or script for every ContrastMaster effect that
you want to apply during batch processing. If you want to apply individual ContrastMaster settings to each image during
batch processing, please activate the small dialog icon next to the ContrastMaster entry in the Action palette. This will
make the ContrastMaster dialog appear for every new image.

Batch Processing in Paint Shop Pro 8 and higher

Paint Shop Pro 8 (and higher) offers a Process feature on the File > Batch menu for batch processing a series of images
with the help of a PSP script. Recording such a script is quite easy.

Recording a PSP script with ContrastMaster:

1. Open an image in PSP.

2. Select File > Script > Start Recording.

3. Choose ContrastMaster from the Effects > Plugins menu.

4. If you want to use Cloak Mode, continue with step 5, because you can adjust the effects settings later. If you do not
want to use Cloak Mode, you now need to adjust the effect settings in ContrastMaster, so that they are recorded in the
script.

5. Press OK on the ContrastMaster dialog.

6. Select File > Script > Stop Recording and save the script. Now you have a ContrastMaster action that you can use with
File > Batch > Process.
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Batch processing a series of images with ContrastMaster:

1. Open one of the images from the image series.

2.  If you want to use Cloak Mode, run ContrastMaster, adjust its settings and enter Cloak Mode by holding the CTRL
key and clicking on the Cancel button. If you do not want to use Cloak Mode, continue with step 3, because you do not
need to run ContrastMaster.

3. Select File > Batch > Process or File > Batch Process.

4. In the Batch Process dialog choose your ContrastMaster script with the Browse button from the Script frame.

5. Set the other batch options and click on the Start button to run it.

If you are using Cloak Mode, please read here: If you want to batch process another series of images with other
ContrastMaster settings, please uncloak ContrastMaster as mentioned above, adjust the settings and return to Cloak
Mode again. You don't need to create another script for that purpose as you would need to do for other plugins. If you
want to apply individual ContrastMaster settings to each image during batch processing, don't activate Cloak mode and
run the script nevertheless. Then for each image the ContrastMaster dialog will pop up.

If you do not use Cloak Mode, read here: You need to record a new script for every ContrastMaster effect that you want
to apply during batch processing. You can create a collection of scripts with various ContrastMaster effect and use these
scripts as you need. If you want to apply individual ContrastMaster settings to each image during batch processing,
please deactivate the "Run script in silent mode" check box in the Batch Process dialog. This will make the
ContrastMaster dialog appear for every new image.
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Batch Processing in Other Applications

There are some other applications that support batch processing with the help of plugins, e.g. Fireworks, Debabelizer and
Photo−Paint. Basically batch processing in other applications works the same as in Photoshop or Paint Shop Pro. In
Fireworks you need to record a script and use Cloak Mode for batch processing. In Photo−Paint you need to record an
script, but do not need to use Cloak Mode, because it already automatically suppresses the ContrastMaster dialog. If you
use ContrastMaster 1.02 for Window in Debabelizer, you do not need to use Cloak Mode, otherwise you do need to.
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Frequently Asked Questions

How is ContrastMaster different from contrast adjustment tools in Photoshop or other
applications?

ContrastMaster offers three special contrast adjustment methods (called Dynamic, Adaptive and Local Contrast) which
are not available in Photoshop and other applications. These can still effectively emphasize contrast in image details
when other conventional contrast tools fails. Furthermore, ContrastMaster offers all contrast adjustment methods in one
dialog. So you can quickly and easily adjust contrast without switching back and forth between various dialogs as you
need to do in Photoshop and other applications. ContrastMaster also offer some masking options for selectively applying
contrast, e.g. to shadows, highlights or areas with certain colors.

I am already doing local contrast adjustments with the Unsharp Mask tool. Why should I use
ContrastMaster?

ContrastMaster offers three methods for adjusting local contrast. These methods are more effective and offer more control
over the effect than the Unsharp Mask tool. So you will achieve much better results with ContrastMaster. Please get the
demo version of ContrastMaster and see yourself.

Can I create HDR images with ContrastMaster?

ContrastMaster is not a HDR tool, because it does not let you combine multiple images of the same scene into one. But
as the product description states, it lets you create HDR−like effects. Many HDR tools need to compress the contrast
range of a HDR image into the lower range of a screen or print. To achieve that they often increase the contrast of
individual image areas while greatly reducing the contrast in other less important and flat image areas. ContrastMaster
does something similar with non−HDR images. It expands the contrast range in some image areas, which makes many
details better visible. So images processed with ContrastMaster may appear as if they were HDR images.

After I apply ContrastMaster on a portrait photo, the person looks much older. What can I do
about it?

You often get an nice effect if you apply ContrastMaster on the portrait of a man or old person. ContrastMaster can
emphasize masculinity or old age, which may make the person look more interesting. ContrastMaster can also produce
nice effect on smooth skin, e.g. the skin of children or older people with a lot of make−up. However, it is not recommended
to increase the contrast of skin area in portraits of young persons or woman without much make−up, otherwise skin
imperfection will show more clearly. So you need to selectively apply the ContrastMaster effect to these portrait photos.

ContrastMaster offers a Mask tab sheet with a color option that lets you remove the effect from skin areas. You just need
to use the color picker tool to select the skin color and move the appropriate slider until the contrast adjustments is
removed from the skin areas. For even more control you can also create a selection or layer mask in your image editing
application for selectively applying the ContrastMaster effect. If you do extensive portrait retouching, you will also need
such a facial mask for other retouching task. Alternatively you can also set the Mix combo boxes in Novice or Expert
Mode to "Edges". This will keep flat skin areas from being contrast adjusted.

Some of my photos contain a white background or a cloudless sky. ContrastMaster adds too
much contrast to these areas whereas the rest of the image looks just fine. What can I do?

Basically this is the same question as the above question about portrait photos. By default ContrastMaster tries to improve
contrast even in areas that have no texture and very little contrast. As a result these areas may look unnatural afterwards.
You could apply a weaker effect or use very high Radius or very small Detail slider values, but usually that is no option,
because it reduces the contrast in textured areas even more. One workaround is to set the Mix combo boxes in Novice or
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Expert Mode to "Edges". This will avoid that the contrast effect is applied to uniform areas like a wall or the sky. Another
options is to use the controls on ContrastMaster's Mask tab sheet to selectively remove the effect. You could also create a
selection or layer mask in your image application if nothing else helps.

ContrastMaster sometimes brings out the noise in my photos. How can I avoid that?

As ContrastMaster lets you boost the contrast in a photo to a high extent, it can make imperfections in bad quality photos
more clearly. You can try to avoid that by applying a less intense ContrastMaster effect to such photos, removing the
effect in shadows with the Shadows slider on the Mask tab sheet in ContrastMaster or sizing down photos before you
apply ContrastMaster. Often it helps a lot to apply noise reduction to the image before or after you apply ContrastMaster.
Using JPEG artifact removal before running ContrastMaster will also help a lot with highly compressed photos. However,
it would be the best if you try to get the best image quality from your camera or scanner in the first place.

ContrastMaster increases the color cast and vignetting in some of my images. Why?

Low contrast photos usually do not exhibit noise, artifacts, color casts or lens vignetting. But when adjusting the contrast
these imperfections become quite visible. As ContrastMaster can improve the contrast quite dramatically, there is also a
good chance that it will make these things more visible. If you do not want to live with lower contrast images, you should
remove noise, artifacts, color casts and lens vignetting before running ContrastMaster. You can also do it after running
ContrastMaster, but doing it before lets you easier judge the effect in ContrastMaster. Another alternative is to improve the
quality of your photos, e.g. by using a DSLR camera, avoiding a high ISO setting and shooting RAW (in case JPG
artifacts are a problem).

Why does ContrastMaster not effectively work on silhouette photos?

ContrastMaster is not meant to be used with photos with extreme contrasts that have one area totally black and the rest of
the photo extremely bright. If you want to remove the shadows from such photos, you better use a shadow/highlight tool
like our LightMachine plugin. After your brightened up the photo you can use ContrastMaster with more success. If the
contrasts are not that extreme in the photo, the Brighten slider in ContrastMaster may already produce the desired result.
If you do not want to lift the shadows in the photo, you can also switch to Global Contrast mode in ContrastMaster for
applying some tonal tweaks.

Sometimes ContrastMaster renders a bit slow after pressing OK. What can I do about it?

The slow down is usually caused by the Adaptive Contrast effect. Although it renders relatively fast on images below 1
Megapixel (like the preview image), it can take up to several minutes to process a 10 Megapixel image on an old single
core processor. If you use a dual or quad core processor, the rendering will be up to two or four times faster. You can
dramatically increase (up to eight times) the rendering of the Adaptive Contrast effect by activating the Speedup check
box on the Adaptive tab sheet. However, the effect will then look a bit different. Sometimes it will look better, but other
times you may want to keep the Speedup check box deactivated and accept the longer rendering time.

Why does the final result of ContrastMaster sometimes look a bit different from the preview?

The preview of ContrastMaster may not display the final result 100% accurately sometimes. That is usually the case with
larger images and smaller Radius values. That is because the preview usually only contains 0.2 to 0.5 Megapixel of image
data whereas the full image is 10 Megapixel image large. As ContrastMaster works on small image details, the small
preview image may not contain enough image details to represent the full image perfectly.

The same problem occurs even graver for all sharpen and noise/grain filters, which work on an even smaller detail level.
For these filters you usually switch to a 100% preview zoom and scroll around to view the effect accurately. You can do
the same with ContrastMaster. Additionally you can improve the preview accuracy by enlarging the ContrastMaster
window and thus the preview. On the other hand the final result often looks even better than the preview, so it may also
mean a positive surprise rather than a problem.

ContrastMaster Manual 23



Reset &Global Presets

Reset Button

If you want to undo the current settings and return to the default values, you can click on the Reset button. This feature is
especially helpful if you start with a new image. The behavior of the Reset button can be changed with the On Reset
combo box on the Prefs tab sheet. For more information, please read the Prefs Tab page.

Right clicking (or CTRL−clicking on the Mac) on the Reset button will display a context menu with various options. The
four options correspond to the options of the On Reset combo box of the Prefs tab: "Default Settings" activates the default
setting and removes any adjustments that you made. "Previous Settings" loads the settings that were applied previously.
"Own Defaults" will automatically open the preset file that you have chosen when selecting the "Own Default" in the Prefs
tab. "Logged Settings" will open a preset that was automatically saved when you worked with the same image the last
time, provided that you had the Log Settings check box in the Prefs tab activated.

Top Button Menu

If you click on the small icon at the left of the Mode combo box, a menu will be displayed. This menu includes options for
opening and saving presets and a list of all presets from the Preset sub folder of the ContrastMaster folder.

Open Presets

Several global presets are already delivered with ContrastMaster, which can be useful as a starting point. Additionally you
can also save your own presets in order to have often needed effect settings at hand. These global presets can only be
chosen with the help of the button menu next to the Mode combo box and change all settings of ContrastMaster. In
contrast to that, local presets are chosen from arrow−down button menus and only influence a few controls.

Save Preset

You can save the current ContrastMaster settings as a preset with the help of the Save Preset option. Please save
presets into the Presets sub folder within the ContrastMaster folder, because this is the location where ContrastMaster
looks for them. You can open a preset later again with the Open Preset menu item.

Preset List

At the bottom of the menu is a list of all ContrastMaster presets from the Presets sub folder of ContrastMaster. If you
choose one of them, it is immediately applied and changes all settings.
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Split View

The various split views let you compare the original image side by side with the resulting image.

Using Left, Right, Bottom and Top View

The Right View displays the effect on the right side of the preview and the Left View displays it on the left side. The
Bottom View displays the effect at the bottom of the preview and the Top View displays it on the top. Same with the other
two options. To move the separation line between the two versions, you need to activate the split view icon at the top right
corner of the preview. The you can use the split view tool to drag the separation line.

Multiple

The Multiple check box only works in combination with the Split View options. If it is activated, you will see the same
image section in each split view area. By default the middle area of the image is displayed in both split views. To display
another part of the image you need to set a focus point by choosing the split view tool at the top right corner of the
preview and clicking somewhere on the preview.
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Histo Tab

ContrastMaster offers various types of histograms. They can be useful to see if a stronger effect benefits or damages the
image.

Histograms basically don't show anything you can't see in the image itself if you know where to look and if you look
closely. But histograms have the advantage that they are more structured than the image itself, so they let you recognize
image problems easier.

A histogram is a statistical display of an image parameter, e.g. brightness, hues or saturation. It shows the distribution of
certain pixel values in an image. These values usually range from 0 to 255 in a 8bit image. The range of these values is
displayed from left to right in the histogram, so the value 0 is displayed at the outer left and the value 255 is displayed on
the outer right side. The amount of each value is displayed from bottom to top, so the height of the curve represents the
number of pixels that have a certain value. If more pixels have a certain value, the histogram curve will be higher at that
point.

In ContrastMaster the histogram curve is separated into three areas: the shadows on the left side (with values from 0 to
85), the midtones in the middle (with values from 86 to 170) and the highlights on the right side (with values from 171 to
255). ContrastMaster displays all three areas equally wide, although some people may argue that the midtones are twice
as wide as the shadows and the highlights. But usually it is more useful to define the three areas equally wide.

Peak, Mean, Shadows, Midtones and Highlights labels

The Peak figure lets you know which brightness, color or other value occurs most often in the image. The histogram curve
usually has its peak at that value. The Mean figure tells you the average brightness, color or other value. If this value is
below 128, the image contains e.g. more dark than bright areas.

The Shadows percentage lets you know how much of the image is in the lower value range (e.g. is quite dark), the
Midtones figure tells you how much of the image is in the middle range (e.g. is moderately bright) and the Highlights
percentage shows you how much of the image is in the upper range (e.g. is bright). For example if the Shadows
percentage in the RGB or Intensity histogram is very high, it can mean that the photo is underexposed.

RGB Histogram

You can use the RGB histogram to see if there are blown highlights or cutoff shadows in an image. Blown highlights can
be identified by a high spike on the right side whereas cutoff shadows are represented by a high spike on the left side.
The higher and wider the spike is, the more information was cut off.
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If there is a large slope on the left or right side and not just a thin spike, then the photo is already quite damaged. Another
bad sign is if the middle part of the curve is quite flat or extremely ducked to the ground. If such histograms are produced
by an adjustment you made in ContrastMaster, you should correct the setting.

The RGB histogram also shows the darkest value (the end point of the curve at the left) and brightest value (the end point
of the curve at the right) in an image. Both are also called black point and white point. The range between both points is
called dynamic or tonal range and determines the contrast of the image. The optimal contrast is achieved if the curve
starts at the outer left and ends at the outer right. If this isn't the case, the image may not have a good contrast. If the
curve starts more towards the middle, it also means that the image is too bright. If it ends more in the middle, then the
image is too dark.

Nevertheless there are always exceptions from the rule. For example, a photo with a snow landscape will produce a
similar histogram as an overexposed photo, but the snow photo is fine while the overexposed photo needs to be fixed. On
the other hand a photo with a black sky and stars or the moon looks on the histogram as if it is underexposed, although
this isn't the case. Another example is a photo that was taken on a foggy day. If you correct its low contrast too much, the
result will look terrible and don't give the viewer the impression of fog anymore. So a good rule is to always investigate the
contents of the image and to not to trust the histogram completely.

Small gaps tend do show up in the RGB Histogram more often than in other histogram types. They are only a sign that an
image was processed and are usually nothing to worry about.

Intensity, Luminosity and Lightness Histograms

The Intensity, Luminosity and Lightness histograms are very similar for many images. They often let you better judge the
brightness distribution in an image, but they are not suitable to judge blown highlights or cutoff shadows. If the image
contains more shadows, the hill is more on the left side. If it contains more highlights, the hill is located on the right side. If
it is well balanced, the hill or hills are usually in the middle of the histogram.

If there are two peaks, one on the outer left side in the shadows and one on the outer right side in the highlights, it can
mean that the photo was taken under extreme light conditions and contains too dark as well as too bright areas. If there
are peaks on both the outer left and right side, the image contrast is usually too extreme.

Red, Green, Blue, Cyan, Magenta and Yellow Histograms

These histograms can be used to recognize color casts or other color problems. For example if the Blue Histogram
contains a curve that is only located in the shadows, it means that there are as good as no light blue areas in the image.
This can mean that the color blue was suppressed in the image and that the image has a yellow color cast.
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Hue Histogram

The Hue histogram lets you see if some hues are missing. If some hues are dominant in the image, it can mean − but not
necessarily − that there is a color cast. A close−up photo for example is usually missing some hues even if it doesn't have
a color cast.

Saturation Histogram

The Saturation histogram lets you see if there is a problem with the saturation in the image. For example if there is
nothing in the left part, the image may be oversaturated or if there is nothing on the right side, the image is probably
undersaturated. However, images with a lot of white and dark areas may appear undersaturated according to the
histogram, but as pure white and black have no saturation, that may not be true.

Colors Histogram

The Colors histogram is similar to the RGB histogram, so it also lets you see if there are blown or cutoff areas.
Additionally it shows which hues are dominant in the shadows, midtones and highlights.

Black and White Histograms

The left part of Black histogram and the right part of the White histogram are similar to the RGB histogram. Both
histograms should fill the whole value range from left to right. The above Black histogram indicates that the image is too
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"black" and too much "white" at the right end of the histogram is missing. The above White histogram also has a small gap
at right end, which means that the white values aren't fully used.

If there is a large gap at the right or left end of the histogram, it means hat the contrast of the image is bad. Spikes at the
outer left or right indicate cutoff shadows and blown highlights.

Styles

ContrastMaster lets you display the histograms in four different styles. "Filled" creates the standard histogram type that is
known from many graphics applications. The "Gradient" option draws a color gradient from left to right. The colors of this
gradient are different from histogram to histogram. The "Line" option draws a line and leaves the area underneath empty.
"Dot" plots the histogram values as dots, which may make some histogram values less readable, but lets you easier
recognize a general trend.
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Info Tab

The Info tab shows information that is not essential but which may be helpful in certain circumstances.

Show Blown Highlights

If the Show Blown Highlights check box is active, a line pattern will be displayed over highlight areas that were cut.
Additionally a percent value in the label of the check box which indicated the percentage of blown highlights. This feature
doesn't show and count blown highlights that were already present in the image before you started ContrastMaster. So it
only indicates problems that was created by a too strong ContrastMaster effect.

The Color Box

When moving the mouse over the preview the color under the cursor is displayed in the color box of the Info tab sheet.
Additionally the color is shown as RGB and HSL values. The Xand Y values represent the image coordinates at which the
color was picked.
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Prefs Tab

The Prefs tab contains some options for defining the behavior of ContrastMaster.

On Start Up

The default On Start Up control is "Previous Settings". This option will load the settings that were previously applied to an
image with ContrastMaster. The "Default Settings" option will set all controls back to the default values.The "Logged
Settings" option will automatically open the settings that were applied the last time to the same image. It only works if you
previously had the Log Settings check box activated and if you use Photoshop or Paint Shop Pro (see below for more
information).

On Reset

The behavior of the Reset button can be defined by the On Reset combo box. If it is set to "Default Settings" and you click
the Reset button, most controls will be deactivated.

If On Reset is set to "Previous Settings", clicking Reset will load the settings that were used for correcting the previous
image. If you select "Own Defaults", you will be prompted to select an existing preset file. So, if you want the Reset button
to revert all controls back to your preferred settings, you must first save these settings to a preset file. See the Presets
page for more information about saving preset files.

If you press the Reset button after setting On Reset to "Logged Settings", ContrastMaster will look in the logfiles sub
folder inside the ContrastMaster folder to see if a preset with the name of the current image has been saved there. This
preset may have been automatically saved by ContrastMaster, because the Log settings check box was activated and
you already applied a correction to this image (or an image with the same file name). If ContrastMaster can find a preset
file, it will immediately open it. If ContrastMaster doesn't find one, nothing will happen.

Deactivate Multiprocessor Support (x CPUs)

If you encounter any problems, you can deactivate the support for multiple processors and hyperthreading processors
with this check box. The number in brackets displays how many processors were detected by ContrastMaster. For
example, for a hyperthreading or dualcore processor you will see "2 CPUs" displayed. If you only have a
non−hyperthreading, singlecore processor, this check box will be disabled by default.

FX Values

If the FX Values check box is activated, the default values will be higher when pressing the Reset button or using the
options of the arrow−down button menu. This concerns the three sliders on the Mix tab sheet as well as the Intensity
sliders in the Dynamic Contrast, Adaptive Contrast and Local Contrast mode. This feature is meant for users who mainly
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use ContrastMaster for dramatic effects and less for photo corrections. The FX Values check box lets them start with
higher default values, which saves them some time, because they do not need to crank up the sliders every time they
press the Reset button or choose e.g. the "Reset" option on a arrow−down button menu.

Histo Zoom

Activating the Histo Zoom check box in the Prefs tab cuts off peaks when displaying a histogram in the Histo tab sheet.
This avoids a flat histogram display where only a few high spikes are visible. That's also how Photoshop displays
histograms. This option is activated by default.

Log Settings

With the Log Settings check box activated ContrastMaster automatically saves preset files in the logfiles sub folder of the
ContrastMaster folder when you press the OK button to apply a correction to an image. In Photoshop and Paint Shop Pro
the presets are named with the file name of the image. In other applications a random number is used, because these
applications don't supply the file name of the image to plugins like ContrastMaster. If you apply ContrastMaster a second
time to the same image and have Log Settings activated, the previous preset file will be overwritten.

At least with Photoshop and Paint Shop Pro this feature allows you to easily find the settings that you applied to certain
images by looking into the logfiles sub folder. For other applications you can only look at the file date and guess which
preset file was used for which image.

In connection with the Logged Settings option of the On Start Up combo box (see above), you can use the Log Settings
check box to automatically make ContrastMaster start up with the settings that were applied the last time to the same
image. So if you need to correct the same image again, you will automatically be presented with the same settings that
you used the last time.

In case you don't want to start up ContrastMaster with the logged settings or forgot to activate that option, you can also
open the logged settings by right clicking on the Reset button and choosing "Logged Settings" from the context menu.
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Key Shortcuts  (Windows Only)

ContrastMaster lets you use a few key shortcuts for performing certain tasks. Advanced computer users usually prefer
using key shortcuts as they help to achieve some tasks much faster. The shortcuts available are indicated by an
underlined letter in the button label. Here is a list of all shortcuts that can be used:

Key Shortcut Explanation

ALT and 1 (Windows only) Switches to the "Preview 1" tab sheet

ALT and 2 (Windows only) Switches to the "Preview 2" tab sheet

ALT and 3 (Windows only) Switches to the "Preview 3" tab sheet

ALT and M (Windows only) Activates or deactivates the Multiple check box

ALT and P
(Windows only) Activates or deactivates the Auto Preview check
box

ALT and R (Windows only) Resets some controls to their default values

ALT and + (Windows only) Increases the preview zoom ratio

ALT and − (Windows only) Decreases the preview zoom ratio

ALT and ? (Windows only) Displays the manual

B
(When the mouse is placed over the preview) Displays a page
with photos of the beta testers.
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Modes

ContrastMaster offers an Novice and Expert mode, which apply all available effects, whereas the remaining four modes
only apply individual contrast effects.

Modes Workflow

Changes that you make in each mode will be transfered if you switch to another mode. Only the values of the Intensity
sliders of the Dynamic Contrast, Adaptive Contrast and Local Contrast modes will no be transfered to the Novice and
Expert mode, because these modes have their own intensity sliders, which work a bit different. For detailed workflow tips
see the Step By Step Guide page.

Novice Mode

Novice Mode offers only a few controls, so it does not let you adjust and use all effects of Contrast Master. For more
details, please read the Mix Tab Sheet and Global Tab Sheet pages. For the Saturation slider see the Saturation Tab
Sheet page.

Global Contrast

Global Contrast mode only applies the global contrast effects. For more details, please read the Global Tab Sheet,
Saturation Tab Sheet and Mask Tab Sheet pages.
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Dynamic Contrast

Dynamic Contrast mode lets you apply the dynamic contrast as well as global contrast effects. For more details, please
read the Dynamic Tab Sheet, Global Tab Sheet, Saturation Tab Sheet and Mask Tab Sheet pages.

Adaptive Contrast

Adaptive Contrast mode lets you apply the adaptive contrast as well as global contrast effects.  For more details, please
read the Adaptive Tab Sheet, Global Tab Sheet, Saturation Tab Sheet and Mask Tab Sheet pages.
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Local Contrast

Local Contrast mode lets you apply the local contrast as well as global contrast effects.  For more details, please read the
Local Tab Sheet, Global Tab Sheet, Saturation Tab Sheet and Mask Tab Sheet pages.

Expert Mode

Expert Mode offers all ContrasMaster controls. It lets you combine the Dynamic, Adaptive and Local Contrast effects with
the help of various mix options and also apply the global contrast effects. For more details, please read the Mix Tab
Sheet, Dynamic Tab Sheet, Adaptive Tab Sheet, Local Tab Sheet, Global Tab Sheet, Saturation Tab Sheet and Mask
Tab Sheet pages.
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Mix Tab Sheet

The Mix tab sheet is available in Novice and Expert Mode. In Novice Mode it only has the upper three sliders displayed.
The Mix tab sheet is for blending the dynamic, adaptive and local contrast effects together and combine the advantages of
the contrast effects.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Dynamic, Adaptive and Local Sliders

The Dynamic, Adaptive and Local sliders determine the intensity of the individual effects as well the ratio with which the
dynamic, adaptive and local effects are mixed into the final result. If all three sliders have the same value, it means that
the three effects are evenly combined and each of the three effects only makes up 1/3 of the final effect. That is also why
the sliders on the Dynamic, Adaptive and Local tab sheets appear to cause less changes in the image than in the
Dynamic Contrast, Adaptive Contrast Local Contrast modes.

If you set one of these sliders to zero, the effect will not be applied. If you want to simulate the Dynamic Contrast mode in
Expert Mode, you need to set the Adaptive and Local sliders to zero. If you want to simulate the Adaptive Contrast mode,
you need to set the Dynamic and Local sliders to zero. And if you want to simulate the Local Contrast mode, you need to
set the Dynamic and Adaptive sliders to zero. However, it is more convenient to choose the appropriate option from the
arrow−down button menu.

So these three sliders do not work exactly as the Intensity sliders in the Dynamic Contrast, Adaptive Contrast and Local
Contrast mode. Only if two of the sliders are set to zero, the remaining slider works the same way.

Dynamic Mix, Adaptive Mix and Local Mix

These three combo boxes determine how the three contrast effects are mixed. The "Normal" option uses the effect over
the whole tonal rage. The "Shadows" option only applies the effect to the shadow range and the "Highlight" option adds it
to the highlights only. The "Edges" option only applies the effect to the edges in the image and the "Surface" option adds it
to the non−edge areas. For example, if you set one combo box to "Shadows" and the other to "Highlights", you will have
one effect added to the shadows and the other effect applied to the highlights.

Setting all combo boxes to "Edges" can help to avoid that the effect is applied to flat image areas ( e.g. a wall or the sky),
which do not benefit from strong contrast. If you do that, you usually also need to set the Dynamic, Adaptive and Local
sliders to very high values.
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Dynamic Tab Sheet

The Dynamic tab sheet controls the dynamic contrast effect. The dynamic contrast effect can produce very dramatic
contrast enhancements and emphasize a lot of details in the image.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Intensity

The Intensity slider is only available in Dynamic Contrast mode. In Expert Mode it is replaced by the Dynamic slider on the
Mix tab sheet. The Intensity adjust the intensity of the effect. A slider value of zero means no effect and a slider value of
100 applies the effect at full intensity.

Detail

The Detail slider adjusts the size of the details that are emphasized. Low slider values focus on large details in the image
whereas high slider values bring out the contrast in small details. The slider value represents the number of sections that
the image is divided into when processing it. So more sections means smaller details. It is basically the inverse of the
Radius slider that is used by the adaptive and local effects.

Strength

The Strength slider may appear to work similar to the Intensity slider, but it does that a bit different. By default it is set to a
value of 50. Lower slider values can help to reduce noise that was made more visible by the dynamic contrast effect. If the
Details slider has a low value, increasing the value of the Strength slider above 50 may not produce a much stronger
effect.

Variation

The Variation slider actually blend with a second dynamic contrast effect which usually produces an even stronger effect
and may create artifacts on bad quality images. At a value of zero the normal dynamic contrast effect is used, at a value
of 100 the second dynamic contrast effect is used and at a value of 50 both effects are applied with equal intensity.
Basically you should only use this slider if you want an even stronger effect.
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Highlights, Shadows

The Highlights slider darkens the highlights at higher slider values and brightens them at lower slider values. The
Shadows slider on the other hand brightens the shadows at higher values and darkens them with lower values. Both
sliders adjust the highlights and shadows using the dynamic contrast algorithm, so they are dependent on it.
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Adaptive Tab Sheet

The Adaptive tab sheet controls the adaptive contrast effect. The adaptive contrast effect is not as dramatic as the
dynamic contrast effect, but is nice for improving the contrast in textured areas. The Adaptive Contrast effect renders quite
fast in a small preview, but needs overproportional longer for large images. Depending on the Radius value and your
processor it can take up to several minutes on a 10 Megapixel image. To avoid that you can also try activating the
Speedup check box.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Intensity

The Intensity slider is only available in Adaptive Contrast mode. In Expert Mode it is replaced by the Adaptive slider on the
Mix tab sheet. The Intensity adjust the intensity of the effect. A slider value of zero means no effect and a slider value of
100 applies the effect at full intensity.

Radius

The Radius slider adjusts the size of the details that are emphasized. Low slider values focus on small details in the
image whereas high slider values bring out the contrast in large details. The unit of the slider is not pixels, but a
percentage of the image size. So the same Radius value will produce the same effect for images of different size.

If the check box at the left of the Radius slider is activated, the radius value varies for each pixel. For example if the
Radius slider is set to 4, the actual radius values will lie between 0.5 to 8. Textured image areas will be processed with a
lower radius value whereas smooth image areas will be processed with a higher radius value. This usually produces a
better look. However, if the Speedup check box is activated, the Radius check box will only double the radius value.

Speedup

The Speedup check box renders the adaptive contrast effect up to eight times faster on large images, but the effect will be
a bit be different. In several cases the effect will be be rougher or of lower quality. The Speedup check box also influences
the behaviour of the Radius check box by only doubling the radius value, which results in a less balanced effect. It also
makes the Range slider work a bit differently.

Range

At high slider values the Range slider emphasizes larger details and produces a softer look. At lower slider values it
makes the effect look more rough and brings out smaller details. A medium slider values is best for avoiding halos or a

ContrastMaster Manual 40



rough look.

Boost

The Boost slider increases the strength of the effect. It is set to a medium value by default. So using lower values will
weaken the effect and higher values will increase the effect strength. Activating the check box at the left of the Boost
slider will emphasize some edges and highlights.

Soften

The Soften slider makes the effect look softer. At high values, it helps to reduce halos, but may produce blown highlights.

Highlight, Shadows

The Highlights slider darkens the highlights at higher slider values and brightens them at lower slider values. The
Shadows slider brightens the shadows at higher values and darkens them at slider values. Both sliders adjust the
highlights and shadows using the adaptive contrast algorithm, so they do not work like the Highlights and Shadows sliders
of the dynamic contrast effect.
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Local Tab Sheet

The Local tab sheet controls the local contrast effect. The local contrast effect often appears less strong than the dynamic
and adaptive contrast effects, but it can effectively emphasize edges and compress the contrast range to enrich the mid
tones.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Intensity

The Intensity slider is only available in Local Contrast mode. In Expert Mode it is replaced by the Local slider on the Mix
tab sheet. The Intensity adjust the intensity of the effect. A slider value of zero means no effect and a slider value of 100
applies the effect at full intensity.

Radius

The Radius slider adjusts the size of the details that are emphasized. Low slider values focus on small details in the
image whereas high slider values bring out the contrast in large details. The unit of the slider is not pixels, but a
percentage of the image size. So the same Radius value will produce the same effect for images of different size.

Compress

The Compress slider moves the shadows and highlights toward the midtones, which effectively means that the shadows
will be brightened and the highlights will be darkened. It makes the image look more evenly lightened. It may produce
halos in some cases, which can be softened with the Soft Light slider.

Expand

The Expand slider works contrary to the Expand slider. It makes the highlights brighter and the shadows darker. It brings
out details in image edges.
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Soft Light

The Soft Light slider modifies the effect of the Compress and Expand sliders. It can soften the harshness of both effects
and make the local contrast effect look less flat. Using a middle value is often the best choice for it.

Shadows

The Shadows slider lets you brighten up the shadows areas. It depends on the local contrast effects, so it does not work
like the Shadows slider on the Dynamic and Adaptive tab sheets.
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Global Tab Sheet

The Global tab sheet lets you apply some global contrast effects. Other than the Dynamic, Adaptive and Local effects,
which adjust the contrast in small neighborhood areas in the image, these global effects take the whole image into
account when adjusting the contrast.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Brighten

The Brighten slider lets you increase or decrease the brightness of the image in EV steps from −3.0 to +3.0. For many
images you will only need adjustments between −1.0 and +1.0 though. It doesn't work like the brightness or gamma
sliders that are known from various graphics applications. It doesn't cut off shadows or highlights and also doesn't change
the contrast.

S−Contrast, H−Contrast, Contrast

The S−Contrast slider lets you decrease and increase the contrast in the shadow areas whereas the H−Contrast slider
does the same for the highlight areas. If you activate the check box at the left of these two sliders, the two sliders will be
combined into one Contrast slider. This Contrast slider adjust the contrast over the whole tonal range. If the S−Contrast
and H−Contrast sliders have the same values, they work identical to the Contrast slider.

Stretch

The Stretch slider adjusts the black and white point of the image. Based on the slider value the appropriate black and
white points are automatically selected and the tonal range of the image is stretched. Some image may need a very high
Stretch value before you see any change, but most image will already show an effect at very low values. So be careful to
not use a extreme value, otherwise you will blow out details in the image.

Please notice: The Stretch effect may look a bit different if only a part of the image is displayed in the preview. That is
because it calculates internal correction values based on the displayed image data. So it can be best judged if you use the
"Fit" zoom option.

Equalize

The Equalize slider distributes the tonal values evenly throughout the image. If you apply it to a high−contrast image, it will
lower the contrast and restore the midtones. If it is applied to a low−contrast image, it will increase the contrast. So it
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depends on the image what effect it produces. Usually it also brightens up the image a bit.

Polarize

The Polarizes slider works similar to polarizing glass filters. Positive slider values make blue areas darker and yellow
areas brighter whereas negative values have the contrary effect. You could also call it a color contrast effect, because it
also slightly modifies the colors of the image. It may do a nice job on some images, but may not work so good on other
images.
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Saturation Tab Sheet

The Saturation tab sheet lets you adjust the saturation of the image. As most contrast effects in ContrastMaster slightly
desaturate the image, it is important to adjust saturation accordingly.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Method

The Method combo box determines what method is used for adjusting the saturation. The "Normal" option uses the
standard method of saturation adjustment. The "Median", "Luminance" and "Intensity" options offer variations of the
normal method. The remaining six options have the name of some colors and adjust saturation based on the various color
channels.

Saturation

The Saturation slider is set to a default value of 10 to compensate for the saturation loss of the contrast effects. For some
portrait photo you may need to set the value to zero to achieve a natural skin color. A value of −100 of the Saturation
slider turns the image to black and white whereas a value of 100 extremely saturates the image.

Sat. Mask

The Sat. Mask slider lets you weaken the saturation in image areas with a higher saturation. So it allows you to increase
saturation in image areas that are less saturated while keeping saturated areas from getting oversaturated.

ContrastMaster Manual 46



Mask Tab Sheet

The Mask tab sheet offers various options for weakening the contrast effect and removing it from certain image areas.
These mask options work quite effectively on most images, but some image may require more extensive masking. In such
cases you need to create a selection or layer mask in your image application.

The Arrow−Down Button

Clicking on the arrow−down button will display a menu with various local presets. These local presets are useful settings
for the controls of the current tab sheet. Each tab sheet has its own arrow−down menu with different presets. Only the
"Reset" option is the same. It sets the controls of the tab sheet to their default values.

Fade

The Fade slider weakens the overall effect of ContrastMaster. A slider value of 100 means that no effect will be applied
and a value of zero applies the effect at full intensity.

Highlights, Shadows

The Highlight slider gradually removes the effect of ContrastMaster in the brighter image areas whereas the Shadows
slider does the same in the darker areas. If you have both sliders set to a high value, the effect of ContrastMaster will only
be applied in the midtone areas.

Color 1, Color 2

The two Color sliders let you remove the ContrastMaster effect in image areas that have a certain color. The color that will
be used is displayed in the color box at the left of the slider. To choose a color for one of the color boxes, you need to
click on the color box to select it and then click somewhere on the preview to pick a color. Please notice that clicking on
one of the two color boxes automatically activates the color picker tool at the top of the preview. Alternatively you can also
click a second time on a color box to display a color dialog for choosing a color.

Once the color was chosen you can move the slider thumb to the right to gradually remove the ContrastMaster effect from
the image area with the selected color. As there are two color boxes you can affect two different color areas at the same
time. For example, you could remove or weaken the ContrastMaster effect in skin areas and in blue sky areas
simultaneously.
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